Page 1 of 1

SF65 and DCA-510 USB datacable

PostPosted: Thu Jul 21, 2005 4:34pm
by RichardB
I recently bought an SF65 which came with a DCA-510 USB cable.

When I installed ithe software that came with the phone (onto a Windows 98SE platform), the USB drivers detected the cable, but insisted there was a driver error, and MPM won't detect the phone. I downloaded the latest drivers from the Siemens website just in case, unistalled the software, re-installed etc. but the same problem re-occurs.

I then did the same with a Windows 2000 platform. This time the USB drivers correctly detect the cable whenever its plugged, allocating COM3. However, MPM and Siemens Explorer etc. still refuse to detect the phone. I've tried all sorts of combinations of switching phone on and off and plugging the cable in and out, but the phone is still not detected.

I've changed the MPM settings to manual, still no detection of the phone. (The Windows device manager always detects the cable though.) The phone always displays "connected" whenever the cable is attached. I've tried several different USB ports (some on my motherboard, some on a PCI card) all with the same result. I have manually reset the COM port to COM12 and tried again. NO success.

Lots of people seems to have trouble getting MPM or any other Siemens software to detect their phone on the end of a DCA-510.


PostPosted: Thu Jul 21, 2005 4:43pm
by SandStorm
Welcome to SP. :D
At first, try this:
[Cable installation Wizzard]

Using these drivers:
[Latest 510 cable drivers]

And this MPM version:
[MPM latest version page]

PostPosted: Thu Jul 21, 2005 7:22pm
by RichardB
I have the cable correctly detected by the device driver. I can see it in the device manager, and no problems are reported.

I have used the latest drivers ( and latest MPM software (v3.04.40.43), downloaded on 19th July, but still no detection of the phone. When trying to connect, the cable's TX and RX LEDs sometimes flash, but the phone is never detected.

PostPosted: Thu Jul 21, 2005 7:33pm
by SandStorm
Try to move the switch you have on the cable.
If it is set to the charge mode, it wont connect, but if you disable the charge, it will connect 8)

PostPosted: Fri Jul 22, 2005 7:37am
by RichardB
I've tried that too, but no luck. As I said, I've also tried a USB1.1 port on the PC's motherboard, and a USB2.0 port on a PCI card, but with the same results.

I have now managed to connect using the same software, phone and cable, but on someone elses computer with XP installed.

If only I could connect on mine!

PostPosted: Fri Jul 22, 2005 2:10pm
by SandStorm
Well, so the best advice is you to move on to Windows 2000 or XP. :roll:

SF65 and DCA 510 USB datacable

PostPosted: Tue Mar 01, 2016 9:02pm
by Lerakroxa
Hello all,
I am using MikroProg on a Windows 8 computer with the EasyPic V7 board. All is working well if I use one particular USB port but if I plug the board into a different USB port then MikroProg does not see the board. I have gone to the USB drop down menu and it is not listed. I have looked in the Device Manager and the computer can see the board with no errors.

If I change the board back to the original USB port then MikroProg can see it again?

Any ideas?

Re: SF65 and DCA-510 USB datacable

PostPosted: Tue Mar 01, 2016 10:53pm
by DireWolf
Hi, and welcome! My laptop (previously Win8, now Win10) has a similar symptom with one of my mice: only when it's plugged into a specific USB port it works.

I'm almost sure that many external USB ports on a computer are actually outputs from an internal USB hub. Perhaps some of them belong to different "hubs" than others on the same computer, hence the different results.

But, if MikroProg works with one of the ports, why not using that port for it and attach the rest of the hardware to the other ports?