Bluetooth problem EF81

Bluetooth problem EF81

Postby aden34 » Thu Mar 22, 2007 12:18am

Hi, i have just got a new EF81 and it was on firmware version 17 so i upfraded to FW 58 which i got from some russian website, i have filled in all my mms etc details from 02 UK , but for some reason my bluetooth connection when i try to turn it on says "bluetooth address not set" what does this mean, any help would be ruly appreciated.
aden34
Hai! I'm new here! Plz help me!!!1
Hai! I'm new here! Plz help me!!!1
 
Posts: 14
Joined: Thu Mar 22, 2007 12:13am

Postby SandStorm » Thu Mar 22, 2007 12:45am

Welcome to siemensplanet.
You will need:

QPST 2.7 build 215
NV Editor

You need to activate the NV item number 447.

Once you get the QPST (you need to google for it, it cames in one bittorrent archive, you need to use bittornado)i send you the NV editor, and post the way how you have to enable it.


I did the same on my prototype E81, had exactly the same problem. ;)
User avatar
SandStorm
Administrator
Administrator
 
Posts: 11447
Joined: Fri Feb 13, 2004 6:53pm
Location: Portugal

Postby aden34 » Thu Mar 22, 2007 1:52am

Hi and thank you Sandstorm, i have now got the QPST file downloaded to my pc.What software can i use to connect my mobile to my pc as i did not get a cd with my phone.Then can i have some instructions please, thank you.
aden34
Hai! I'm new here! Plz help me!!!1
Hai! I'm new here! Plz help me!!!1
 
Posts: 14
Joined: Thu Mar 22, 2007 12:13am

Postby SandStorm » Thu Mar 22, 2007 2:52am

Since you upgraded the phone, you already have the usb drivers.
Now, launch the QPST configurator.
Click on "add new port"
Type the port number your phone is using now. (you put it COM5, COM10, etc, its just one example)

Now, lets download NV editor. [Download the Editor]

launch the NV editor, maximize the window.
on connect, select the com port, and press connect server.
press the file button and select upload all from mobile
Then, press the search button, and type "447"
Move the file to the "selected" window.
Once you double click it, in another window you will see loads of firlds with 0
Change the to 1, all of them.
also, change the string value to "true"
Now, you press the "file" button and press "download selected & active to mobile"
Disconnect the server, close the program, unplug the phone, and restart the phone.
Now, try to enavble the bluetooth.
User avatar
SandStorm
Administrator
Administrator
 
Posts: 11447
Joined: Fri Feb 13, 2004 6:53pm
Location: Portugal

Postby aden34 » Thu Mar 22, 2007 10:33pm

Hi SandStorm, i have started carrying out your instructions and have got as far as change string value to "true" , where is the string value.Thank you.
aden34
Hai! I'm new here! Plz help me!!!1
Hai! I'm new here! Plz help me!!!1
 
Posts: 14
Joined: Thu Mar 22, 2007 12:13am

Postby SandStorm » Thu Mar 22, 2007 10:53pm

Attention, the string is not called value!

Well, Iguess is better for me and you, if i upload some explanatory images. ;)
User avatar
SandStorm
Administrator
Administrator
 
Posts: 11447
Joined: Fri Feb 13, 2004 6:53pm
Location: Portugal

Postby aden34 » Thu Mar 22, 2007 11:07pm

Wow, thank you Sandstorm , that was an amazingly quick response.
aden34
Hai! I'm new here! Plz help me!!!1
Hai! I'm new here! Plz help me!!!1
 
Posts: 14
Joined: Thu Mar 22, 2007 12:13am

Postby SandStorm » Thu Mar 22, 2007 11:17pm

Lol man. :)
I will see if today i have it ready.
User avatar
SandStorm
Administrator
Administrator
 
Posts: 11447
Joined: Fri Feb 13, 2004 6:53pm
Location: Portugal

Postby SandStorm » Fri Mar 23, 2007 12:22am

Ok, here goes the tutu. :)

Remember, once you do the 6th image step, you go to connection and select disconnect server :)
My used com port is different from yours, but if is the same, the better xD
Attachments
Tutorial with images.rar
the tutorial to enable the BT adress item.
(304.84 KiB) Downloaded 14350 times
User avatar
SandStorm
Administrator
Administrator
 
Posts: 11447
Joined: Fri Feb 13, 2004 6:53pm
Location: Portugal

Postby aden34 » Fri Mar 23, 2007 8:01am

Oh my god Sandstorm it works, i can not thank you enough!!! What makes guys like you go to all this trouble for a perfect stranger just to get their mobiles working.You ask for nothing yet give everything, your a special person, thank you.One more quick one , what software can i use to transfer files to and from my mobile, i have downloaded a thing called MPManager but it just keeps saying phone not connected.
aden34
Hai! I'm new here! Plz help me!!!1
Hai! I'm new here! Plz help me!!!1
 
Posts: 14
Joined: Thu Mar 22, 2007 12:13am

Postby DireWolf » Fri Mar 23, 2007 9:02am

Heh heh, that's why he sometimes is "SaintStorm". :lol:
About software, you can use SXG75 Controller or Komunikátor. Links to download both can be found here.
User avatar
DireWolf
Administrator
Administrator
 
Posts: 4541
Joined: Sun Jul 17, 2005 10:29pm
Location: Barreiro, Portugal

Postby SandStorm » Fri Mar 23, 2007 1:13pm

How fate is. :)
I won a prototype E81, upgraded it from FW 0.000001 to FW19, managed to produce one internal antenna, and with lots of work, found the tools and how-to-do to enable my BT, that had exactly the same problem. :)

Destiny wanted it to happen, then, I could provide you a proper support :P
User avatar
SandStorm
Administrator
Administrator
 
Posts: 11447
Joined: Fri Feb 13, 2004 6:53pm
Location: Portugal

Postby andnewman » Wed Apr 25, 2007 6:00pm

The bytes in that NV item is the BT-address, I found my opld address in one of my phones, so I'm happy, I can go back to it! :D
User avatar
andnewman
I think I'm cool cause I have >100 posts
I think I'm cool cause I have >100 posts
 
Posts: 477
Joined: Sat Sep 16, 2006 12:02pm
Location: Norway

Postby SandStorm » Wed Apr 25, 2007 6:04pm

Gr8 ;)

Ok, now, your hard problem is just the service mode :)
User avatar
SandStorm
Administrator
Administrator
 
Posts: 11447
Joined: Fri Feb 13, 2004 6:53pm
Location: Portugal

Postby Vlad000 » Fri Jun 15, 2007 11:07am

Hello to everybody!

I heave just same problem as adnen34, my bluetooth wont work.
So I did everything like you say (followed instructions on pics) and when I go to "download selected and active to mobile" this message shows up ""NV_BD_ADDR_I ID = 447 is write protected. It cant be downloaded to Mobile Phone!"

Can anyone help me, please?
Vlad000
Hai! I'm new here! Plz help me!!!1
Hai! I'm new here! Plz help me!!!1
 
Posts: 2
Joined: Fri Jun 15, 2007 10:57am

Postby SandStorm » Fri Jun 15, 2007 3:15pm

reboot computer, reboot phone, and do really exactly like the tutorial says.
Of course, first you need to have the phone recognized by QPST, as the QPST needs to be exactly the same version thats mentioned there.
User avatar
SandStorm
Administrator
Administrator
 
Posts: 11447
Joined: Fri Feb 13, 2004 6:53pm
Location: Portugal

Postby Vlad000 » Sat Jun 16, 2007 12:10pm

I did everything "by the book", and now bluetooth is OK :D
Vlad000
Hai! I'm new here! Plz help me!!!1
Hai! I'm new here! Plz help me!!!1
 
Posts: 2
Joined: Fri Jun 15, 2007 10:57am

Postby SandStorm » Sat Jun 16, 2007 10:41pm

great you have it working now. ;)

another happy costumer :D
User avatar
SandStorm
Administrator
Administrator
 
Posts: 11447
Joined: Fri Feb 13, 2004 6:53pm
Location: Portugal

Postby CMcK » Fri Aug 10, 2007 1:18pm

I had the same Bluetooth problem listed above. I used the tutorial to alter the values in '447' but the bluetooth still isn't working properly.

Transfers from the computer are failing. The rate is really slow and files never seem to finish.

[/img]
Siemens phones I've owned: SL55, CF62, S68, E71, EL71 (silver), EF81 (away for repairs) and another EL71 (black) .
CMcK
Follower of N00Byism
Follower of N00Byism
 
Posts: 40
Joined: Sat Jul 28, 2007 10:15pm

Postby m@dmax » Fri Aug 10, 2007 8:17pm

Did BT transfer work properly before the fw-update?
i'm just a signature, nothing else
one of my phones
I think I'm cool cause I have >100 posts ;)
User avatar
m@dmax
I think I'm cool cause I have >100 posts
I think I'm cool cause I have >100 posts
 
Posts: 127
Joined: Sat Jun 23, 2007 9:51pm
Location: Bavaria/Germany
Next

Return to EF51, EF71, EF81 and EF91

Who is online

Users browsing this forum: No registered users and 1 guest